Compatibility

This page shows you what components and services Gitpod is and is not compatible with. It is aimed at both individual developers that use Gitpod as well as admins that install and maintain a Gitpod Self-Hosted instance. You can filter the table to show only what is relevant to you.

Note: It is required to have at least one of each category. SaaS users can ignore the self-hosted specific categories (see filter)

Yes supported

untested untested

No not supported

Category
Component
Status
Support Policy
Supported Versions
Browser
Google Chrome
Yes
current version
current version
Safari
Yes
current version
current version
Firefox
Yes
current version
current version
IDE
VS Code Browser
Yes
current version
current version
VS Code Desktop
Yes
current version
current version
IntelliJ IDEA
Yes
current version
current version
GoLand
Yes
current version
current version
PyCharm
Yes
current version
current version
CLI (SSH)
Yes
current version
current version
Source Control Management System (SCM)
GitHub.com
Yes
current version
current version
GitHub Enterprise Server
Yes
all officially supported versions
GitLab.com
Yes
current version
current version
GitLab Self-Managed
Yes
all officially supported versions
Bitbucket.org
Yes
current version
current version
Bitbucket Server
Yes
> v7.20 (Jan 2022)
> v7.20 (Jan 2022)
Operating System (Kernel)
Linux Kernel
Yes
> 5.4
5.4 < x < 5.15
Operating System (Distribution)
Ubuntu
Yes
20.04 and 22.04
20.04 and 22.04
Amazon Linux
untested
Orchestration System
Kubernetes
Yes
the last three minor releases
1.22, 1.23 and 1.24
Orchestration Platform
Amazon Elastic Kubernetes Service (EKS)
Yes
see Kubernetes support policy
see Kubernetes support policy
Google Kubernetes Engine (GKE)
Yes
see Kubernetes support policy
see Kubernetes support policy
Azure Kubernetes Service (AKS)
Yes
see Kubernetes support policy
see Kubernetes support policy
K3s
untested
see Kubernetes support policy
see Kubernetes support policy
Container Runtime
containerd
Yes
1.5 and 1.6.
1.5 and 1.6.
Container Network Interface (CNI)
Calico VXLAN
Yes
current version
current version
Certificate Management Tools
Cert Manager
Yes
> 1.5
> 1.5
Object Storage
AWS S3
Yes
current version
current version
Google Cloud Storage (GCS)
Yes
current version
current version
Azure
Yes
current version
current version
MiniIO backed by in-cluster storage
Yes
Image Registry
MinIO backed by AWS S3
Yes
Amazon Elastic Container Registry (ECR)
No
Google Container Registry (GCR)
Yes
current version
current version
Google Artifact Registry (GAR)
Yes
current version
current version
Azure Container Registry (ACR)
Yes
current version
current version
Artifactory
untested
Other Docker Registry API compliant registries
untested
In-cluster registry
Yes
Database
External MySQL Database
Yes
5.7
5.7
In-cluster MySQL database
Yes

Was this helpful?